BREW-FONTTOOLS-CVE-2026-111497 (GHSA-9V8H-QQGM-4M35)
Vulnerability from osv_homebrew – Published: 2026-10-26 09:30 – Updated: 2026-10-26 09:30 – Source websiteA buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.
Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.
{
"affected": [
{
"ecosystem_specific": {
"fix": "bump",
"range_state": "fixed",
"resource": "brotli",
"resource_purl": "pkg:pypi/brotli@1.2.1",
"upstream_fixed_in": "1.2.1"
},
"package": {
"ecosystem": "Homebrew",
"name": "fonttools",
"purl": "pkg:brew/fonttools"
},
"ranges": [
{
"events": [
{
"introduced": "4.34.4_1"
},
{
"fixed": "4.45.0"
},
{
"introduced": "4.49.0"
},
{
"fixed": "4.67.0_1"
}
],
"type": "ECOSYSTEM"
}
]
}
],
"database_specific": {
"confidence": "high",
"source": "matched",
"strategy": "registry",
"upstream_evidence": [
{
"ecosystem": "PyPI",
"key": "pkg:pypi/brotli@1.2.1",
"name": "brotli",
"resource": "brotli",
"strategy": "registry",
"subject_version": "1.2.1"
}
]
},
"details": "A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.\n\nUsers need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.",
"id": "BREW-fonttools-CVE-2026-111497",
"modified": "2026-10-26T09:30:41Z",
"published": "2026-10-26T09:30:41Z",
"references": [
{
"type": "ADVISORY",
"url": "https://nvd.nist.gov/vuln/detail/CVE-2026-111497"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/commit/0ed4268a4401abcb4472096340477cf4af7d1a2b"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/commit/50a9b70a4d5e1443fc40927952276b68fffa83a0"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/commit/b418fa81c48262a86a95332b0bc6d62c30aa78b6"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/commit/da9806362874b9bd4b552a3af360b5d6347beb12"
},
{
"type": "WEB",
"url": "https://www.cve.org/CVERecord?id=CVE-2026-111497"
},
{
"type": "WEB",
"url": "https://pypi.org/project/brotlicffi"
},
{
"type": "WEB",
"url": "https://pypi.org/project/Brotli"
},
{
"type": "WEB",
"url": "https://opensourcemalware.com/blog/node2shell-affects-python"
},
{
"type": "WEB",
"url": "https://nodejs.org/en/blog/vulnerability/october-2026-security-releases#nodejs-brotli-decoder-out-of-bounds-write-permits-remote-code-execution-cve-2026-111497---high"
},
{
"type": "WEB",
"url": "https://nodejs.org/en/blog/vulnerability/october-2026-security-releases"
},
{
"type": "WEB",
"url": "https://github.com/pypa/advisory-database/tree/main/vulns/brotlicffi/PYSEC-2026-4323.yaml"
},
{
"type": "WEB",
"url": "https://github.com/pypa/advisory-database/tree/main/vulns/brotli/PYSEC-2026-4322.yaml"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/releases/tag/v1.2.1"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/releases/tag/v1.1.1"
},
{
"type": "WEB",
"url": "https://github.com/google/brotli/releases/tag/v1.0.10"
},
{
"type": "PACKAGE",
"url": "https://github.com/google/brotli"
}
],
"schema_version": "1.7.3",
"severity": [
{
"score": "CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N",
"type": "CVSS_V4"
}
],
"summary": "Brotli: Out-of-bounds write in the Brotli decoder (\"Node2Shell\") also affects the PyPI Brotli package",
"upstream": [
"GHSA-9v8h-qqgm-4m35",
"BIT-node-2026-111497",
"BIT-node-min-2026-111497",
"CVE-2026-111497",
"PYSEC-2026-4322",
"PYSEC-2026-4323"
]
}
Drag nodes to arrange them. Double-click a related vulnerability to open it, or a source to visit its link. The Physics button on the left tunes the layout and the simulation; the legend at the bottom left hides or shows nodes by kind and by sighting type.
Sightings
| Author | Source | Type | Date | Other |
|---|
Nomenclature
- Seen: The vulnerability was mentioned, discussed, or observed by the user.
- Confirmed: The vulnerability has been validated from an analyst's perspective.
- Published Proof of Concept: A public proof of concept is available for this vulnerability.
- Exploited: The vulnerability was observed as exploited by the user who reported the sighting.
- Patched: The vulnerability was observed as successfully patched by the user who reported the sighting.
- Not exploited: The vulnerability was not observed as exploited by the user who reported the sighting.
- Not confirmed: The user expressed doubt about the validity of the vulnerability.
- Not patched: The vulnerability was not observed as successfully patched by the user who reported the sighting.
Vulnerability timeline
Sightings and recorded dates, grouped by day · UTC
Loading timeline…
The approach is described in our paper Mapping CVEs to MITRE ATT&CK Techniques: A Curated Gold-Set Classifier and the Limits of LLM-Assisted Label Expansion.
Browse all ATT&CK techniques and the vulnerabilities related to each.
Related by attack behaviour
Vulnerabilities whose description is nearest to this one in the vector space of the CIRCL/vulnerability-attack-technique-biencoder model. This is a similarity search over the bi-encoder space (plain cosine), not a classification, and it has no measured accuracy.