<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en">
  <id>https://db.gcve.eu/rss/recent/all/10</id>
  <title>Most recent entries from all</title>
  <updated>2026-10-28T22:54:58.947959+00:00</updated>
  <author>
    <name>Vulnerability-Lookup</name>
    <email>info@gcve.eu</email>
  </author>
  <link href="https://db.gcve.eu" rel="alternate"/>
  <generator uri="https://lkiesow.github.io/python-feedgen" version="1.0.0">python-feedgen</generator>
  <subtitle>Contains only the most 10 recent entries.</subtitle>
  <entry>
    <id>https://db.gcve.eu/vuln/bit-node-2026-111497</id>
    <title>BIT-node-2026-111497</title>
    <updated>2026-10-28T22:54:58.950645+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> Bitnami: node</p>
<p>A flaw in Node.js can cause Node.js Brotli decoder out-of-bounds write permits remote code execution. This vulnerability affects Node.js 22.x, 24.x, and 26.x.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/bit-node-2026-111497"/>
  </entry>
  <entry>
    <id>https://db.gcve.eu/vuln/cve-2026-111497</id>
    <title>CVE-2026-111497 — Out-of-Bounds Write in Google Brotli Decoder</title>
    <updated>2026-10-28T22:54:58.950706+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> Google Brotli</p>
<p>A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.</p>
<p>Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/cve-2026-111497"/>
  </entry>
  <entry>
    <id>https://db.gcve.eu/vuln/ghsa-9v8h-qqgm-4m35</id>
    <title>GHSA-9v8h-qqgm-4m35 — Brotli: Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package</title>
    <updated>2026-10-28T22:54:58.950744+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> PyPI: brotli, PyPI: brotlicffi</p>
<p>A buffer overflow vulnerability in the Brotli decoder (c/dec/decode.c) in Google Brotli versions 1.0.3 through 1.2.0 on all platforms allows a remote unauthenticated attacker to corrupt adjacent decoder state memory, disclose sensitive memory contents, cause a denial of service, or potentially execute arbitrary code using a crafted Brotli-compressed stream.</p>
<p>Users need to update any Brotli libraries or binaries between 1.0.3 through 1.2.0 to the latest available version: 1.0.10 or 1.1.1 or 1.2.1.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/ghsa-9v8h-qqgm-4m35"/>
  </entry>
  <entry>
    <id>https://db.gcve.eu/vuln/pysec-2026-4322</id>
    <title>PYSEC-2026-4322 — Out-of-bounds write in the Brotli decoder ("Node2Shell") also affects the PyPI Brotli package</title>
    <updated>2026-10-28T22:54:58.950771+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> PyPI: brotli</p>
<p>CVE-2026-111497 ("Node2Shell") is an out-of-bounds write (CWE-787) in Google's
Brotli decoder (c/dec/decode.c). DecodeBlockTypeAndLength() returns an ambiguous
value for an invalid block switch, and the fast decode path discards it
(CWE-252, unchecked return value), so a crafted Brotli stream makes the decoder
continue on corrupted state and write past the ring buffer. Upstream rates it
CVSS 4.0 9.2 and classifies the impact as potential remote code execution.</p>
<p>The vulnerability is in Google's C library, not in Node.js specifically. The
PyPI `Brotli` package is Google's CPython binding and compiles the same
c/dec/decode.c that has the actual vulnerability. All `Brotli` releases up to
and including 1.2.0 ship the vulnerable decoder; 1.2.1 contains the upstream
fix (commit 0ed4268a) and differs from 1.2.0 only in that fix plus a version
bump.</p>
<p>The decoder is reached whenever untrusted Brotli data is decompressed. With
`Brotli` installed, common HTTP clients decode Brotli responses automatically
(urllib3/requests, httpx with the brotli extra, aiohttp) and services that
accept `Content-Encoding: br` request bodies decode inbound data, so the flaw
is reachable from attacker-controlled input.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/pysec-2026-4322"/>
  </entry>
</feed>
