UBUNTU-CVE-2025-31672 (CVE-2025-31672)
Vulnerability from osv_ubuntu – Published: 2025-04-09 12:15 – Updated: 2026-10-17 09:31 – Source websiteImproper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.
{
"affected": [
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "3.10.1-2"
}
]
},
"package": {
"ecosystem": "Ubuntu:16.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@3.10.1-2?arch=source\u0026distro=xenial"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.10.1-2"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-1~18.03"
}
]
},
"package": {
"ecosystem": "Ubuntu:18.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-1~18.03?arch=source\u0026distro=bionic"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"3.10.1-3",
"4.0.1-1~18.03"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-1"
}
]
},
"package": {
"ecosystem": "Ubuntu:20.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-1?arch=source\u0026distro=focal"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-1"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-3"
}
]
},
"package": {
"ecosystem": "Ubuntu:22.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-3?arch=source\u0026distro=jammy"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-1",
"4.0.1-2",
"4.0.1-3"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-6"
}
]
},
"package": {
"ecosystem": "Ubuntu:24.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-6?arch=source\u0026distro=noble"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-4",
"4.0.1-5",
"4.0.1-6"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-6"
}
]
},
"package": {
"ecosystem": "Ubuntu:25.10",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-6?arch=source\u0026distro=questing"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-6"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-6"
}
]
},
"package": {
"ecosystem": "Ubuntu:26.10",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-6?arch=source\u0026distro=stonking"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-6"
]
},
{
"ecosystem_specific": {
"binaries": [
{
"binary_name": "libapache-poi-java",
"binary_version": "4.0.1-6"
}
]
},
"package": {
"ecosystem": "Ubuntu:26.04:LTS",
"name": "libapache-poi-java",
"purl": "pkg:deb/ubuntu/libapache-poi-java@4.0.1-6?arch=source\u0026distro=resolute"
},
"ranges": [
{
"events": [
{
"introduced": "0"
}
],
"type": "ECOSYSTEM"
}
],
"versions": [
"4.0.1-6"
]
}
],
"aliases": [],
"details": "Improper Input Validation vulnerability in Apache POI. The issue affects the parsing of OOXML format files like xlsx, docx and pptx. These file formats are basically zip files and it is possible for malicious users to add zip entries with duplicate names (including the path) in the zip. In this case, products reading the affected file could read different data because 1 of the zip entries with the duplicate name is selected over another but different products may choose a different zip entry. This issue affects Apache POI poi-ooxml before 5.4.0. poi-ooxml 5.4.0 has a check that throws an exception if zip entries with duplicate file names are found in the input file. Users are recommended to upgrade to version poi-ooxml 5.4.0, which fixes the issue. Please read https://poi.apache.org/security.html for recommendations about how to use the POI libraries securely.",
"id": "UBUNTU-CVE-2025-31672",
"modified": "2026-10-17T09:31:46Z",
"published": "2025-04-09T12:15:00Z",
"references": [
{
"type": "REPORT",
"url": "https://ubuntu.com/security/CVE-2025-31672"
},
{
"type": "REPORT",
"url": "https://www.cve.org/CVERecord?id=CVE-2025-31672"
},
{
"type": "REPORT",
"url": "https://www.openwall.com/lists/oss-security/2025/04/08/2"
},
{
"type": "REPORT",
"url": "https://bz.apache.org/bugzilla/show_bug.cgi?id=69620"
}
],
"related": [],
"schema_version": "1.7.0",
"severity": [
{
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N",
"type": "CVSS_V3"
},
{
"score": "medium",
"type": "Ubuntu"
}
],
"upstream": [
"CVE-2025-31672"
]
}
Drag nodes to arrange them. Double-click a related vulnerability to open it, or a source to visit its link. The Physics button on the left tunes the layout and the simulation; the legend at the bottom left hides or shows nodes by kind and by sighting type.
Sightings
| Author | Source | Type | Date | Other |
|---|
Nomenclature
- Seen: The vulnerability was mentioned, discussed, or observed by the user.
- Confirmed: The vulnerability has been validated from an analyst's perspective.
- Published Proof of Concept: A public proof of concept is available for this vulnerability.
- Exploited: The vulnerability was observed as exploited by the user who reported the sighting.
- Patched: The vulnerability was observed as successfully patched by the user who reported the sighting.
- Not exploited: The vulnerability was not observed as exploited by the user who reported the sighting.
- Not confirmed: The user expressed doubt about the validity of the vulnerability.
- Not patched: The vulnerability was not observed as successfully patched by the user who reported the sighting.
Vulnerability timeline
Sightings and recorded dates, grouped by day · UTC
Loading timeline…
The approach is described in our paper Mapping CVEs to MITRE ATT&CK Techniques: A Curated Gold-Set Classifier and the Limits of LLM-Assisted Label Expansion.
Browse all ATT&CK techniques and the vulnerabilities related to each.
Related by attack behaviour
Vulnerabilities whose description is nearest to this one in the vector space of the CIRCL/vulnerability-attack-technique-biencoder model. This is a similarity search over the bi-encoder space (plain cosine), not a classification, and it has no measured accuracy.