GHSA-F6G6-PJGC-5CJ5
Vulnerability from github – Published: 2024-03-19 09:30 – Updated: 2024-11-22 20:51Improper Input Validation vulnerability in Apache Hop Engine. This issue affects Apache Hop Engine: before 2.8.0.
Users are recommended to upgrade to version 2.8.0, which fixes the issue.
When Hop Server writes links to the PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped. The variable not properly escaped is the "id", which is not directly accessible by users creating pipelines making the risk of exploiting this low.
This issue only affects users using the Hop Server component and does not directly affect the client.
{
"affected": [
{
"package": {
"ecosystem": "Maven",
"name": "org.apache.hop:hop"
},
"ranges": [
{
"events": [
{
"introduced": "0"
},
{
"fixed": "2.8.0"
}
],
"type": "ECOSYSTEM"
}
]
}
],
"aliases": [
"CVE-2024-24683"
],
"database_specific": {
"cwe_ids": [
"CWE-20"
],
"github_reviewed": true,
"github_reviewed_at": "2024-03-20T15:31:47Z",
"nvd_published_at": "2024-03-19T09:15:06Z",
"severity": "MODERATE"
},
"details": "Improper Input Validation vulnerability in Apache Hop Engine. This issue affects Apache Hop Engine: before 2.8.0.\n\nUsers are recommended to upgrade to version 2.8.0, which fixes the issue.\n\nWhen Hop Server writes links to the\u00a0PrepareExecutionPipelineServlet page one of the parameters provided to the user was not properly escaped.\nThe variable not properly escaped is the \"id\", which is not directly accessible by users creating pipelines making the risk of exploiting this low.\n\nThis issue only affects users using the Hop Server component and does not directly affect the client.",
"id": "GHSA-f6g6-pjgc-5cj5",
"modified": "2024-11-22T20:51:08Z",
"published": "2024-03-19T09:30:33Z",
"references": [
{
"type": "ADVISORY",
"url": "https://nvd.nist.gov/vuln/detail/CVE-2024-24683"
},
{
"type": "PACKAGE",
"url": "https://github.com/apache/hop"
},
{
"type": "WEB",
"url": "https://lists.apache.org/thread/ts203zssv1n9qth1wdlhk2bhos3vcq6t"
},
{
"type": "WEB",
"url": "http://www.openwall.com/lists/oss-security/2024/03/18/1"
}
],
"schema_version": "1.4.0",
"severity": [
{
"score": "CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N",
"type": "CVSS_V3"
}
],
"summary": "Improper Input Validation vulnerability in Apache Hop Engine"
}
Drag nodes to arrange them. Double-click a related vulnerability to open it, or a source to visit its link. The Physics button on the left tunes the layout and the simulation; the legend at the bottom left hides or shows nodes by kind and by sighting type.
Sightings
| Author | Source | Type | Date | Other |
|---|
Nomenclature
- Seen: The vulnerability was mentioned, discussed, or observed by the user.
- Confirmed: The vulnerability has been validated from an analyst's perspective.
- Published Proof of Concept: A public proof of concept is available for this vulnerability.
- Exploited: The vulnerability was observed as exploited by the user who reported the sighting.
- Patched: The vulnerability was observed as successfully patched by the user who reported the sighting.
- Not exploited: The vulnerability was not observed as exploited by the user who reported the sighting.
- Not confirmed: The user expressed doubt about the validity of the vulnerability.
- Not patched: The vulnerability was not observed as successfully patched by the user who reported the sighting.
Vulnerability timeline
Sightings and recorded dates, grouped by day · UTC
Loading timeline…
The approach is described in our paper Mapping CVEs to MITRE ATT&CK Techniques: A Curated Gold-Set Classifier and the Limits of LLM-Assisted Label Expansion.
Browse all ATT&CK techniques and the vulnerabilities related to each.
Related by attack behaviour
Vulnerabilities whose description is nearest to this one in the vector space of the CIRCL/vulnerability-attack-technique-biencoder model. This is a similarity search over the bi-encoder space (plain cosine), not a classification, and it has no measured accuracy.