<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<rss xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" version="2.0">
  <channel>
    <title>Most recent entries from all</title>
    <link>https://db.gcve.eu</link>
    <description>Contains only the most 10 recent entries.</description>
    <docs>http://www.rssboard.org/rss-specification</docs>
    <generator>python-feedgen</generator>
    <language>en</language>
    <lastBuildDate>Sat, 31 Oct 2026 19:27:00 +0000</lastBuildDate>
    <item>
      <title>CVE-2026-61627 — libass: Out-of-bounds read and write in wrap_lines_measure</title>
      <link>https://db.gcve.eu/vuln/cve-2026-61627</link>
      <description>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; libass&lt;/p&gt;
&lt;p&gt;libass is a portable subtitle renderer for the `ASS`/SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in `wrap_lines_measure` while rendering malicious `ASS` content. In `wrap modes other than two`, a final line ending with a literal backslash-n sequence and otherwise consisting only of such sequences or spaces can remain after early trimming and make the line-measurement loops overshoot by one glyph. When the total text size exactly matches the allocated glyph-array capacity, the first loop reads an uninitialized 32-bit fixed-point `pos.x` value, although that value is not subsequently used. The second loop writes `pos.x` and `pos.y` beyond the array, zeroing the first and adding an attacker-controllable offset to the second. No actual exploitation beyond possible denial of service is known; broader exploitation is theoretical and constrained by the addresses, limited writes, and ASLR. This issue is fixed in version 0.17.5.&lt;/p&gt;</description>
      <content:encoded>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; libass&lt;/p&gt;
&lt;p&gt;libass is a portable subtitle renderer for the `ASS`/SSA (Advanced Substation Alpha/Substation Alpha) subtitle format. Prior to 0.17.5, libass can overread and overwrite the glyph array in `wrap_lines_measure` while rendering malicious `ASS` content. In `wrap modes other than two`, a final line ending with a literal backslash-n sequence and otherwise consisting only of such sequences or spaces can remain after early trimming and make the line-measurement loops overshoot by one glyph. When the total text size exactly matches the allocated glyph-array capacity, the first loop reads an uninitialized 32-bit fixed-point `pos.x` value, although that value is not subsequently used. The second loop writes `pos.x` and `pos.y` beyond the array, zeroing the first and adding an attacker-controllable offset to the second. No actual exploitation beyond possible denial of service is known; broader exploitation is theoretical and constrained by the addresses, limited writes, and ASLR. This issue is fixed in version 0.17.5.&lt;/p&gt;</content:encoded>
      <guid isPermaLink="false">https://db.gcve.eu/vuln/cve-2026-61627</guid>
    </item>
    <item>
      <title>USN-8815-1 — libass vulnerabilities</title>
      <link>https://db.gcve.eu/vuln/usn-8815-1</link>
      <description>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; Ubuntu:Pro:14.04:LTS: libass, Ubuntu:Pro:18.04:LTS: libass, Ubuntu:Pro:20.04:LTS: libass, Ubuntu:Pro:24.04:LTS: libass, Ubuntu:Pro:26.04:LTS: libass&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled parsing operations for
specific nested character strings. An attacker could use this issue to
cause libass to crash, resulting in a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 14.04 LTS,
Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS.
(CVE-2020-24994)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain outline
processing operations. An attacker could use this issue to cause libass
to crash, resulting in a denial of service. This issue only affected
Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-26682)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain ASS subtitle
files when measuring wrapped lines. An attacker could use this issue to
cause libass to crash, resulting in a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 24.04 LTS and
Ubuntu 26.04 LTS. (CVE-2026-61627)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain Matroska
subtitle chunks with negative ReadOrder values. An attacker could use
this issue to cause libass to crash, resulting in a denial of service,
or possibly execute arbitrary code. This issue only affected Ubuntu
26.04 LTS. (CVE-2026-61626)&lt;/p&gt;</description>
      <content:encoded>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; Ubuntu:Pro:14.04:LTS: libass, Ubuntu:Pro:18.04:LTS: libass, Ubuntu:Pro:20.04:LTS: libass, Ubuntu:Pro:24.04:LTS: libass, Ubuntu:Pro:26.04:LTS: libass&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled parsing operations for
specific nested character strings. An attacker could use this issue to
cause libass to crash, resulting in a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 14.04 LTS,
Ubuntu 16.04 LTS, Ubuntu 18.04 LTS and Ubuntu 20.04 LTS.
(CVE-2020-24994)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain outline
processing operations. An attacker could use this issue to cause libass
to crash, resulting in a denial of service. This issue only affected
Ubuntu 18.04 LTS and Ubuntu 20.04 LTS. (CVE-2020-26682)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain ASS subtitle
files when measuring wrapped lines. An attacker could use this issue to
cause libass to crash, resulting in a denial of service, or possibly
execute arbitrary code. This issue only affected Ubuntu 24.04 LTS and
Ubuntu 26.04 LTS. (CVE-2026-61627)&lt;/p&gt;
&lt;p&gt;It was discovered that libass incorrectly handled certain Matroska
subtitle chunks with negative ReadOrder values. An attacker could use
this issue to cause libass to crash, resulting in a denial of service,
or possibly execute arbitrary code. This issue only affected Ubuntu
26.04 LTS. (CVE-2026-61626)&lt;/p&gt;</content:encoded>
      <guid isPermaLink="false">https://db.gcve.eu/vuln/usn-8815-1</guid>
    </item>
  </channel>
</rss>
