<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<rss xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" version="2.0">
  <channel>
    <title>Most recent entries from all</title>
    <link>https://db.gcve.eu</link>
    <description>Contains only the most 10 recent entries.</description>
    <docs>http://www.rssboard.org/rss-specification</docs>
    <generator>python-feedgen</generator>
    <language>en</language>
    <lastBuildDate>Mon, 02 Nov 2026 12:26:08 +0000</lastBuildDate>
    <item>
      <title>GHSA-g857-hhfv-j68w — Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption</title>
      <link>https://db.gcve.eu/vuln/ghsa-g857-hhfv-j68w</link>
      <description>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; RubyGems: zlib&lt;/p&gt;
&lt;p&gt;### Details&lt;/p&gt;
&lt;p&gt;A buffer overflow vulnerability exists in `Zlib::GzipReader`.&lt;/p&gt;
&lt;p&gt;The `zstream_buffer_ungets` function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity.&lt;/p&gt;
&lt;p&gt;### Recommended action&lt;/p&gt;
&lt;p&gt;We recommend to update the `zlib` gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead:&lt;/p&gt;
&lt;p&gt;* For Ruby 3.2 users: Update to zlib 3.0.1
* For Ruby 3.3 users: Update to zlib 3.1.2&lt;/p&gt;
&lt;p&gt;You can use gem update zlib to update it. If you are using bundler, please add `gem &amp;#34;zlib&amp;#34;, &amp;#34;&amp;gt;= 3.2.3&amp;#34;` to your Gemfile.&lt;/p&gt;
&lt;p&gt;### Affected versions&lt;/p&gt;
&lt;p&gt;zlib gem 3.2.2 or lower&lt;/p&gt;
&lt;p&gt;### Credits&lt;/p&gt;
&lt;p&gt;[calysteon](https://hackerone.com/calysteon)&lt;/p&gt;
&lt;p&gt;### References&lt;/p&gt;
&lt;p&gt;* https://hackerone.com/reports/3467067&lt;/p&gt;</description>
      <content:encoded>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; RubyGems: zlib&lt;/p&gt;
&lt;p&gt;### Details&lt;/p&gt;
&lt;p&gt;A buffer overflow vulnerability exists in `Zlib::GzipReader`.&lt;/p&gt;
&lt;p&gt;The `zstream_buffer_ungets` function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity.&lt;/p&gt;
&lt;p&gt;### Recommended action&lt;/p&gt;
&lt;p&gt;We recommend to update the `zlib` gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead:&lt;/p&gt;
&lt;p&gt;* For Ruby 3.2 users: Update to zlib 3.0.1
* For Ruby 3.3 users: Update to zlib 3.1.2&lt;/p&gt;
&lt;p&gt;You can use gem update zlib to update it. If you are using bundler, please add `gem &amp;#34;zlib&amp;#34;, &amp;#34;&amp;gt;= 3.2.3&amp;#34;` to your Gemfile.&lt;/p&gt;
&lt;p&gt;### Affected versions&lt;/p&gt;
&lt;p&gt;zlib gem 3.2.2 or lower&lt;/p&gt;
&lt;p&gt;### Credits&lt;/p&gt;
&lt;p&gt;[calysteon](https://hackerone.com/calysteon)&lt;/p&gt;
&lt;p&gt;### References&lt;/p&gt;
&lt;p&gt;* https://hackerone.com/reports/3467067&lt;/p&gt;</content:encoded>
      <guid isPermaLink="false">https://db.gcve.eu/vuln/ghsa-g857-hhfv-j68w</guid>
    </item>
  </channel>
</rss>
