<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<rss xmlns:atom="http://www.w3.org/2005/Atom" xmlns:content="http://purl.org/rss/1.0/modules/content/" version="2.0">
  <channel>
    <title>Most recent entries from all</title>
    <link>https://db.gcve.eu</link>
    <description>Contains only the most 10 recent entries.</description>
    <docs>http://www.rssboard.org/rss-specification</docs>
    <generator>python-feedgen</generator>
    <language>en</language>
    <lastBuildDate>Thu, 05 Nov 2026 04:58:04 +0000</lastBuildDate>
    <item>
      <title>GHSA-r9px-m959-cxf4 — go-git clients vulnerable to DoS via maliciously crafted Git server replies</title>
      <link>https://db.gcve.eu/vuln/ghsa-r9px-m959-cxf4</link>
      <description>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; Go: gopkg.in/src-d/go-git.v4, Go: github.com/go-git/go-git/v5, Go: github.com/go-git/go-git&lt;/p&gt;
&lt;p&gt;### Impact
A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.13`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients.&lt;/p&gt;
&lt;p&gt;This is a `go-git` implementation issue and does not affect the upstream `git` cli.&lt;/p&gt;
&lt;p&gt;### Patches
Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.13` in order to mitigate this vulnerability.&lt;/p&gt;
&lt;p&gt;### Workarounds
In cases where a bump to the latest version of `go-git` is not possible, we recommend limiting its use to only trust-worthy Git servers.&lt;/p&gt;
&lt;p&gt;## Credit
Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.&lt;/p&gt;</description>
      <content:encoded>&lt;p&gt;&lt;strong&gt;Affected:&lt;/strong&gt; Go: gopkg.in/src-d/go-git.v4, Go: github.com/go-git/go-git/v5, Go: github.com/go-git/go-git&lt;/p&gt;
&lt;p&gt;### Impact
A denial of service (DoS) vulnerability was discovered in go-git versions prior to `v5.13`. This vulnerability allows an attacker to perform denial of service attacks by providing specially crafted responses from a Git server which triggers resource exhaustion in `go-git` clients.&lt;/p&gt;
&lt;p&gt;This is a `go-git` implementation issue and does not affect the upstream `git` cli.&lt;/p&gt;
&lt;p&gt;### Patches
Users running versions of `go-git` from `v4` and above are recommended to upgrade to `v5.13` in order to mitigate this vulnerability.&lt;/p&gt;
&lt;p&gt;### Workarounds
In cases where a bump to the latest version of `go-git` is not possible, we recommend limiting its use to only trust-worthy Git servers.&lt;/p&gt;
&lt;p&gt;## Credit
Thanks to Ionut Lalu for responsibly disclosing this vulnerability to us.&lt;/p&gt;</content:encoded>
      <guid isPermaLink="false">https://db.gcve.eu/vuln/ghsa-r9px-m959-cxf4</guid>
    </item>
  </channel>
</rss>
