<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en">
  <id>https://db.gcve.eu/rss/recent/all/10</id>
  <title>Most recent entries from all</title>
  <updated>2026-11-02T12:26:08.210436+00:00</updated>
  <author>
    <name>Vulnerability-Lookup</name>
    <email>info@gcve.eu</email>
  </author>
  <link href="https://db.gcve.eu" rel="alternate"/>
  <generator uri="https://lkiesow.github.io/python-feedgen" version="1.0.0">python-feedgen</generator>
  <subtitle>Contains only the most 10 recent entries.</subtitle>
  <entry>
    <id>https://db.gcve.eu/vuln/ghsa-g857-hhfv-j68w</id>
    <title>GHSA-g857-hhfv-j68w — Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption</title>
    <updated>2026-11-02T12:26:08.212530+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> RubyGems: zlib</p>
<p>### Details</p>
<p>A buffer overflow vulnerability exists in `Zlib::GzipReader`.</p>
<p>The `zstream_buffer_ungets` function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity.</p>
<p>### Recommended action</p>
<p>We recommend to update the `zlib` gem to version 3.2.3 or later. In order to ensure compatibility with bundled version in older Ruby series, you may update as follows instead:</p>
<p>* For Ruby 3.2 users: Update to zlib 3.0.1
* For Ruby 3.3 users: Update to zlib 3.1.2</p>
<p>You can use gem update zlib to update it. If you are using bundler, please add `gem "zlib", "&gt;= 3.2.3"` to your Gemfile.</p>
<p>### Affected versions</p>
<p>zlib gem 3.2.2 or lower</p>
<p>### Credits</p>
<p>[calysteon](https://hackerone.com/calysteon)</p>
<p>### References</p>
<p>* https://hackerone.com/reports/3467067</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/ghsa-g857-hhfv-j68w"/>
  </entry>
</feed>
