<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en">
  <id>https://db.gcve.eu/rss/recent/all/10</id>
  <title>Most recent entries from all</title>
  <updated>2026-11-02T11:20:46.624035+00:00</updated>
  <author>
    <name>Vulnerability-Lookup</name>
    <email>info@gcve.eu</email>
  </author>
  <link href="https://db.gcve.eu" rel="alternate"/>
  <generator uri="https://lkiesow.github.io/python-feedgen" version="1.0.0">python-feedgen</generator>
  <subtitle>Contains only the most 10 recent entries.</subtitle>
  <entry>
    <id>https://db.gcve.eu/vuln/cleanstart-2026-qj14820</id>
    <title>CLEANSTART-2026-QJ14820 — Security fix for GHSA-g857-hhfv-j68w applied in: ruby 3.2.10-r0</title>
    <updated>2026-11-02T11:20:46.625847+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> CleanStart: ruby</p>
<p>Security vulnerability affects the ruby package. This issue is resolved in later releases. See references for vulnerability details.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/cleanstart-2026-qj14820"/>
  </entry>
  <entry>
    <id>https://db.gcve.eu/vuln/cve-2026-27820</id>
    <title>CVE-2026-27820 — zlib: Buffer Overflow in Zlib::GzipReader ungetc via large input leads to memory corruption</title>
    <updated>2026-11-02T11:20:46.625928+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> ruby zlib</p>
<p>zlib is a Ruby interface for the zlib compression/decompression library. Versions 3.0.0 and below, 3.1.0, 3.1.1, 3.2.0 and 3.2.1 contain a buffer overflow vulnerability in the Zlib::GzipReader. The zstream_buffer_ungets function prepends caller-provided bytes ahead of previously produced output but fails to guarantee the backing Ruby string has enough capacity before the memmove shifts the existing data. This can lead to memory corruption when the buffer length exceeds capacity. This issue has been fixed in versions 3.0.1, 3.1.2 and 3.2.3.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/cve-2026-27820"/>
  </entry>
</feed>
