<?xml version='1.0' encoding='UTF-8'?>
<?xml-stylesheet href="/static/style.xsl" type="text/xsl"?>
<feed xmlns="http://www.w3.org/2005/Atom" xml:lang="en">
  <id>https://db.gcve.eu/rss/recent/all/10</id>
  <title>Most recent entries from all</title>
  <updated>2026-10-26T14:20:25.777984+00:00</updated>
  <author>
    <name>Vulnerability-Lookup</name>
    <email>info@gcve.eu</email>
  </author>
  <link href="https://db.gcve.eu" rel="alternate"/>
  <generator uri="https://lkiesow.github.io/python-feedgen" version="1.0.0">python-feedgen</generator>
  <subtitle>Contains only the most 10 recent entries.</subtitle>
  <entry>
    <id>https://db.gcve.eu/vuln/fkie_cve-2026-104847</id>
    <title>fkie_cve-2026-104847</title>
    <updated>2026-10-26T14:20:25.798697+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml">
        <p>ProseMirror's view component renders and manages the editable browser interface for ProseMirror documents. Prior to 1.42.3, prosemirror-view paste handling accepts attacker-provided HTML whose clipboard slice context contains attributes that are not passed through schema attribute validation. When a user pastes the crafted HTML into an editor, the unvalidated context attributes can construct content that executes attacker-controlled JavaScript in the browser window containing the editor. This issue is fixed in version 1.42.3.</p>
      </div>
    </content>
    <link href="https://db.gcve.eu/vuln/fkie_cve-2026-104847"/>
  </entry>
  <entry>
    <id>https://db.gcve.eu/vuln/ghsa-c8x8-7fp4-3x9w</id>
    <title>GHSA-c8x8-7fp4-3x9w — ProseMirror has a XSS vulnerability in prosemirror-view's paste handling</title>
    <updated>2026-10-26T14:20:25.798770+00:00</updated>
    <content type="xhtml">
      <div xmlns="http://www.w3.org/1999/xhtml"><p><strong>Affected:</strong> npm: prosemirror-view</p>
<p>### Impact</p>
<p>When a user pastes attacker-provided HTML into a ProseMirror editor component, this can cause attacker-controlled JavaScript code to run in the browser window containing the editor.</p>
<p>### Patches</p>
<p>Version 1.42.3 adds validation that prevents this attack.</p>
<p>### Workarounds</p>
<p>No known workarounds.</p></div>
    </content>
    <link href="https://db.gcve.eu/vuln/ghsa-c8x8-7fp4-3x9w"/>
  </entry>
</feed>
